Составить программу в С++, печатающую значение true , если указанное высказывание является истинным , и false в противном случае : числа a и b выражают длины катетов одного прямоугольного треугольника , а c и d - другого . Эти треугольники являются подобными . на языке С ++

#include
using namespace std;

int main()
{
    double a,b,c,d;
    cout << "Enter 1st-triangle catheti here: " << endl;
    cin >> a >> b;
    cout << "Enter 2nd-triangle catheti here: " << endl;
    cin >> c >> d;

    bool podobie = ((a/c == b/d) || (a/d == b/c));

    cout << boolalpha;
    cout << podobie;
    
    cin.get();
    cin.get();
    return 0;
}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку