Напишите программу в turbo pascal: найти корни квадратного уравнения ax^2+bx+c
Var a,b,c,d,x,x1,x2:real;
begin
readln(a.b.c);
d:=sqr(b) - 4*a*c;
if d<0 then
write(нет корней)
else
If d=0 then begin
x:=-b/(2*a);
write(x); end
else begin
x1:=(-b+sqrt(d)/(2*a);
x2:=(-b-sqrt(d))/(2*a);
write(x1,x2);end;
readln
end.
Оцени ответ
