Напишите программу, которая определяет, верно ли, что введённое число состоит из одинаковых цифр. (ABC pascal)
Var x,x1,k,s:integer; d:real;
begin
readln(x);
k:=0; s:=0;
while x>0 do
begin
x1:=x mod 10;
k:=k+1;
s:=s+x1;
x:=x div 10;
end;
d:=s/k;
if d=x1 then writeln(Верно)
else writeln(Неверно);
end.
x-вводимое число, x1-каждая цифра, k-кол-во цифр, s-сумма цифр, d-среднее арифметическое цифр
Оцени ответ
