Написать программу поиска любого элемента в массиве.
Для уточнения - на языке программирования, для программы Паскаль.

Program pm;
uses crt;
var X:array[1..1000] of integer; k,a,b,i:integer;
begin
clrscr;
write(Введите кол-во элементов массива: );
read(k);
writeln;
write(Введите диапазон значений заполнения(A-начальное значение, B-конечное): );
repeat
read(a,b);
until a<=b;
writeln;
randomize;
for i:=1 to k do X[i]:=random(b-a+1)+a;
writeln(Ваш массив:);
for i:=1 to k do write(X[i]:5);
writeln;
write(Введите элемент поиска: );
read(b);
a:=0;
for i:=1 to k do if X[i]=b then a:=i;
if a>0 then writeln(Элемент со значением ,b, имеет индекс ,a)
else writeln(Элемента не существует!);
readkey;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку