Напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено число 0. В конце работы программы на экран выводится минимальное и максимальное из введенных чисел (не считая 0).
Program N94780249;
const
s: longint = 0;
var
x: longint;
t: string;
e: integer;
begin
writeln(Вводите целые числа (0 - окончание ввода) : );
repeat
repeat
write(> );
readln(t);
val(t, x, e);
if e <> 0 then
writeln(Ошибка! Повторите ввод. )
until e = 0;
s += x
until x = 0;
if s = 0 then
writeln(Числа не вводились. )
else
writeln(Сумма введённых чисел = , s, #10);
write(Для завершения работы нажмите Enter...);
readln
end.
Оцени ответ
