Помогите пожауйста написать программу, которая выводит на экран значения функции y=f(x). Аргумент x принимает значения от x1 до x2 с шагом дельто x, а цикл организуется с помощью оператора repeat. a) y=2x; b)y=x/3+9; c) y=x-4; d) y= x/8-6. ( это 4 программы, помогите решить хотя бы 1, чтобы я смогла разобраться с этой темой))

Давайте сделаем так:
Опишем 4 функции в программе. Когда надо - вытащим нужную...  ОК?

uses Crt;
var x1, x2 , dx, y: real;
    i: integer;
function f1 (x:real):real;
 begin
   f1:=2*x;
end;

function f2 (x: real):real;
 begin
   f2:=x/3+9;
 end;

function f3 (x:real):real;
begin
  f3:=x-4;
end;

function f4 (x: real):real;
begin
  f4:=x/8-6;
end;

begin
ClrScr;
Write( x1 = ); ReadLn(x1);
Write( x2 = ); ReadLn(x2);
Write ( dx = ); ReadLn(dx);
i:=1;
repeat
   WriteLn(f1(i):6:3);
   i:=i+1;
until i>x2;
ReadLn;
end.

Например, задавая х1= -10
                               х2= 10
                               dx = 1  получаем значения для первой функции

Записав WriteLn (f3(i):6:3); - получаем значения для третьей функции и так далее....



Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку