Написать в Паскале
111. Мышонок Джерри улепетывает к своей норке по прямой. Успеет ли кот Том догнать Джерри, если Джерри находится как раз на полпути между Томом и норкой?
118. Даны коэффициенты квадратного уравнения a,b,c. Найти действительные корни этого уравнения.
122. Можно ли прямоугольный пакет размерами A,B,C положить в чемодан размерами X,Y,Z?
123.Составить программу вычисления значения функций:
а)1 при x>= 0;
y=0 при x<0
б)x^2 при x>0
y=-x при x<=0
в)1 при x>=1
y=0 при -1 -1 при x<=-1
u)x-1 при x>1
y=0 при -1<=x<=1
x+1 при x<-1
118. Даныкоэффициенты квадратного уравнения a,b,c. Найти действительные корни этогоуравнения.
programKv_ur;
vara,b,c,x1,x2,D: real;
begin
Writeln (Для решения квадратного уравнения);
Writeln (Введите коэффициент a);
Readln (a);
Writeln (Введите коэффициент b);
Readln (b);
Writeln (Введите коэффициент c);
Readln (c);
D:=Sqr(b)-4*a*c;
If d<0 then Writeln (Так как дискрименант ,D,<0уравнение не имеет решений);
begin
If d=0 then
begin
x1:=-b/(2*a);
Writeln (Так как дискриминант равен 0 уравнение имеет один корень:);
Writeln(x1);
end;
If d>0 then
begin
x1:=(-b-Sqrt(Sqr(b)-4*a*c))/2*a;
x2:=(-b+Sqrt(Sqr(b)-4*a*c))/2*a;
Writeln (Так как дискриминант ,D,>0 уравнение имеет два корня:);
Writeln (x1=, x1, и x2=, x2);
end;
end;
end.
122. Можно липрямоугольный пакет размерами A,B,C положить в чемодан размерами X,Y,Z?
programchemodan;
vara,b,c,x,y,z: real;
begin
Writeln(введите размеры пакета);
Writeln(Введите длину a);
Readln (a);
Writeln(Введите ширину b);
Readln (b);
Writeln(Введите высоту c);
Readln (c);
Writeln(введите размеры чемодана);
Writeln(Введите длину х);
Readln(x);
Writeln(Введите ширину y);
Readln(y);
Writeln(Введите высоту z);
Readln (z);
If(a<=x) and (b<=y) and (c<=z) then Writeln (пакет можно положить)
else Writeln(пакет положить нельзя);
End.
