Даны действительные числа х и у, не равные друг другу. Меньшее из этих двух чисел заменить половиной их суммы, а большее - их удвоенным произведением.
Напишите пожалуйста программу в языке С++, очень нужно
вот алгоритм, пожалуйста помогите написать программу
#include
using namespace std;
int main()
{
float x, y, c;
cin>>x>>y;
if (x>y)
{
c = x;
x = 2*x*y;
y = (c+y) / 2.0;
cout<<"x>y"<
else
{
c = x;
x = (x+y)/2.0;
y = 2*c*y;
cout<<"x
cout<<"x = "<
return 0;
}
Оцени ответ
