Как составить программу вычисления и выдачи на печать суммы (или произведения) N элементов бесконечного числового ряда .Следует пользоваться операторами цикла FOR:y=125(-25)5(-1)0,2....
1 var k,i,n,c:integer;
2 p,w:real;
3 begin
4 repeat
5 write(k>-3 k=);
6 readln(k);
7 until k>-3;
8 w:=0;
9 c:=1;
10 for i:=-3 to k do
11 begin
12 c:=-c;{-1^i}
13 p:=1;
14 for n:=i to 2*k do
15 if n<>2 then p:=p*(n*n*n-8);
16 if i<>5 then w:=w+(c/sqr(i-5))*p;
17 end;
18 write(W=,w:0:4)
19 end.
Это?
Оцени ответ
