Помогите с заданием по информатике!!!
нужно составить программу в Паскале
условие: даны три числа
И нужно доказать что они принадлежат отрезку [е; f]
Uses Crt;
var E, F, X, Y, Z: real;
bol: boolean;
begin
ClrScr;
Write( E = ); ReadLn(E);
Write( F = ); ReadLn(F);
Write( X = ); ReadLn(X);
Write( Y = ); ReadLn(Y);
Write( Z = ); ReadLn(Z);
bol:=(X>=E) and (X<=F) and (Y>=E) and (Y<=F) and (Z>=E) and (Z<=F);
if bol=true then Writeln ( Принадлежат !!!)
else WriteLn ( Нет...);
ReadLn;
end.
Оцени ответ
