PASCAL
Написать программу для нахождения принадлежности точки с координатами x,y заштрихованной области
У меня получилось вот так...
Пожалуйста, протестируй программу обязательно!
uses Crt;
var X,Y: real;
bol: boolean;
begin
ClrScr;
Write( X = ); ReadLn(X);
Write( Y = ); ReadLn(Y);
bol:=(Y>=0) and (Y<=sqrt(9-x*x)) and (Y<=3-X/2);
if bol=true then Writeln ( Yes!!!)
else WriteLn ( No...);
ReadLn;
end.
Оцени ответ
