Дано трехзначное число. Напишите программу, которая определяет есть ли среди цифр заданого целого трехзначного числа одинаковые цифры.
var
a,i : integer;
b : array [1..3] of integer;
begin
readln (a);
for i := 1 to 3 do
begin
b[i] := a mod 10;
a := a div 10;
end;
If (b[1] = b[2]) or (b[2] = b[3])
or (b[1] = b[3]) then
writeln (Есть одинаковые цифры)
else
writeln (Нет);
readln ();
end.
Оцени ответ
