Решить в целых числах уравнение ax + b = 0.
Входные данные
Вводятся 2 целых числа: a и b.
Выходные данные
Необходимо вывести все решения, если их число конечно, “NO” (без кавычек), если решений нет, и “INF” (без кавычек), если решений бесконечно много.
В Паскале, пожалуйста!)

Var
  a,b:integer;
begin
  Write(Введите a,b: ); Read(a,b);
  if a<>0 then
    if (b mod a)=0 then Writeln(-b div a) else Writeln(NO)
  else
    if b=0 then Writeln(INF) else Writeln(NO)
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку