Составить программу вычисляющую площадь произвольного треугольника со сторонами a b c в программе pascal

Program prog;
uses crt;
var
a,b,c,s,p:real;
begin
write(a = );
readln(a);
write(b = );
readln(b);
write(c = );
readln(c);

if (a>0) and (b>0) and (c>0)  then
begin
p:=(a+b+c)/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln(S = ,s:0:3);
end;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку