
Программирование в Pascal)
Надо написать программу.
1.N=20 Определить сумму отрицательных элементов массива.
2.Сдвинуть элементы массива на одну позицию вправо, последний элемент переместить на первое место.
3.Все положительные элементы исходного массива записать во второй массив, все отрицательные элементы – в третий массив.

1.
Program A1;
const n=20;
var
i,a:integer;
O:array[1..n] of integer;
begin
a:=0;
for i:=1 to n do begin
readln(o[i]);
if o[i]<0 then a:=a+o[i];
end;
writeln(a);
end.
2.
Program A1;
const n=20;
var
i,a:integer;
O:array[1..n] of integer;
begin
a:=0;
for i:=1 to n do readln(o[i]);
a:=o[n];
for i:=n-1 downto 1 do o[i+1]:=o[i];
o[1]:=a;
for i:=1 to n do write( ,o[i], );
end.
3.
Program A1;
const n=20;
var
i,a:integer;
O:array[1..n] of integer;
P:array[1..n] of integer;
M:array[1..n] of integer;
begin
for i:=1 to n do begin
readln(o[i]);
if o[i]>0 then p[i]:=o[i];
if o[i]<0 then m[i]:=o[i];
end;
for i:=1 to n do write( ,o[i], );
writeln;
for i:=1 to n do
if p[i]<>0 then
write( ,p[i], );
writeln;
for i:=1 to n do
if m[i]<>0 then
write( ,m[i], );
writeln;
end.
Оцени ответ