написать программу на языке Паскаля . Заданы координаты двух точек. Определите, расположены ли они на одной окружности с центром в начале координат. Результат присвоить символьной переменной. Две точки находятся на одной окружности, если длины радиус-векторов, соединяющих эти точки с началом координат, равны (проверку на равенство осуществить с точностью до е=1.0Е-3)

var x1,x2,y1,y2:real;

a:string;
begin
readln(x1,y1);
readln(x2,y2);
if abs(x1/y1)=abs(x2/y2) then a:=Na odnoi okrujnosti else a:=Ne na odnoi okrujnosti;

writeln(a);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку
×