Составить программу для решения следующей задачи : Найти натуральное число от 1 до 10000 с с максимальной суммой делителей.
var n,k: integer;begin n:=1; while n<10000 do begin k:=n+1; n:=n*k; end; n:=n div k; writeln(число: ,n);end.
Оцени ответ
