Бизнесмен Василий после прочтения известной книги решил открыть новый бизнес – отгружать апельсины бочками. Партнерам важно знать сколько именно бочек апельсинов отгружается каждый день.
Мобильный телефон Василия поддерживает только транслит, поэтому он передает сообщения вида "N bochek" . Например, "3 bochki" или "1 bochka"/ Напишите программу, которая выбирает правильное слово (из "bochka" , "bochek" , "bochki" ) в зависимости от N.
Program vasil ;
var n , m : integer ;
begin
write ( vvedi chislo bochek N= ) ;
readln ( n ) ;
m := n mod 10 ;
if ( m = 1 and n <> 11 ) then writeln ( n , bochka )
else if (m <= 4 and n <> 12 and n <> 13 and n <> 14 and m <> 0) then writeln ( n , bochki )
else writeln ( n , bochek ) ;
end.
Так, наверное. Если будет косяк, то пиши, или сам сообрази где ошибка. Сейчас нет под рукой компилятора, не могу оттестировать.
Оцени ответ
