Напишите программу,которая находит сумму цифр введённого пятизначного натурального числа

Var a,s:integer;
begin
  repeat
    writeln(Введите число );readln(a);
  until (a>10000) and (a<99999);
  while a<>0 do begin
    s:=s+a mod 10;
    a:=a div 10;
  end;
  writeln(Сумма цифр:,s);
end.

Тестовое решение:
Введите число
56743
Сумма цифр:25

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку