Напишите программу,которая находит сумму цифр введённого пятизначного натурального числа

Var A,S,k:integer;
begin
S:=0;
write(Введите A = );Readln(A); 
 while (A>0) do    begin   
          If (k<5) then begin     
               k:=k+1;     S:=S+A mod 10;     A:=A div 10;     
               end   
          else begin
                  k:=100;A:=0;
                end; 
           end;  
f(k=5) then 
     write(S) 
else
      write(не пятизнач); 
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку