Написать программу, которая по введенному значению аргумента вычисляет значение функции, заданной в виде графика. Параметр R вводится с клавиатуры.
Var
r,y:real;
begin
readln(r);
if (r>=-7)and(r<=-3)then
y:=r+7;
if (r>=-3)and(r<=-2)then
y:=4;
if (r>=-2)and(r<=2)then
y:=sqr(r);
if (r>=2)and(r<=4)then
y:=-2*r+8;
writeln(y);
if (r<-7)or(r>4)then
writeln(Введите значение в диапазоне [-7;4]);
end.
Оцени ответ
